Update – Media Uploads Incident
Resolved
Jul 10, 2026 at 5:51am UTC
Resolved – Media uploads incident
The issue affecting media uploads and processing has been resolved.
New media uploads and processing are now operating normally. Existing media and playback were not affected.
We will continue monitoring the system closely to ensure everything remains stable.
Affected services
Created
Jul 9, 2026 at 3:33pm UTC
We are currently experiencing an issue affecting media uploads. Some users may see uploads fail, remain stuck in processing, or take longer than usual to become available.
The issue is related to a temporary restriction applied by one of our infrastructure providers after an automated security-risk detection. We have already secured the affected account, identified the suspicious credential involved, deactivated it, and are working with the provider to fully restore access.
Core video playback and existing media are not affected. The impact is limited mainly to new media uploads and processing.
We will post another update as soon as upload processing is fully restored.
Affected services